Issues with PLCSIM and FactoryIO

Hi,

I installed FactoryIO yesterday and was running it without a single Issue. I am using TIA Portal and PLCSim V16. Today I wasn’t able to get it run a single time. I’m using the template provided by the website (same as yesterday). I/O doesn’t get updated in Run Mode, it only updates a single time when switching between Run/Stop in PLCSim. There’s also something crashing because PLCSim goes into Error and stops my simulation. Only thing I can see when that is happening is my local modules going into fault without any message or anything.

Things I tried:

  • Starting TIA and Factory IO as Admin
  • Starting TIA and PLCSim first, going into run, then start FIO as admin

Nothing worked so far. Anyone has an idea what I can do? Thanks!

1 Like

Hello,

the most important thing is. Never change the hardware-configuration of the template. If you add or remove modules there can be an error like you have.

If you have an Error in PLCSIM check the diagnosticbuffer oft the virtual CPU. You wil find more and detailed informations there.

Kind regards

Florian (sps4you)

1 Like

Hi,

Be sure that you have installed the latest updates of TIA Portal V16 and PLCSim V16.

  • TIA Portal V16 update 2 (06/2020)
  • PLCSim V16 update 2 (06/2020)

From the Siemens report of PLCSim V16 Update 2:
Stability when working with the TIA Portal has been improved, partly based on the feedback from returned crash reports.

You can check and install it from the TIA Updater or download it from the Siemens site.

1 Like