S7-PLCSIM V5 I/O not working

When I/O from S7-PLCSIM V5 doesn’t work you probably need to add I/O modules assigned to the addresses used in Factory I/O.

Factory I/O reads and writes to the peripheral input/output (PI/PQ memory areas) of S7-PLCSIM V5. When using a hardware configuration with no peripheral I/O modules PI and PQ are empty and therefore no changes are made to the I and Q images, making it seem like the communication between Factory I/O and PLCSIM is not working.

Adding I/O modules to the station usually fixes the issue. Please note that the modules should use the same addresses as the ones used by Factory I/O.

You can also refer to a step-by-step guide on how to connect Factory I/O with S7-PLCSIM V5.

Hi @m_imrak,
Did you follow the setting up guide?
If so, what was the error message displayed when connection failed?

Yes I followed the setting up side but failed. First I tried in the TIA PORTAL V16 with Factory(2.4.3) . There are pictures about the problem.

By the way in Factory IO, S7 1200 and 1500 run. Only S7 300 is a problem!!

On the other hand I tried same steps with SIMATIC MANAGER 5.6 and Factory IO (2.4.3) runs!

Hi m_imrak,

You have to start the simulator inside TIA Portal and not from the Windows menu.

  • When I start the simulator from the Windows menu I have the same problem
  • But when I start the simulator inside TIA Portal the problem seems to be solved

Hereby a screenshot “how to start the simulator inside TIA Portal”.

Sorry, I couldnt reply you about your solution. I am a new member of this community. So I couldnt reply more than 3 answers :frowning: . Thats why I deleted one of the photo of this conversation.I tried your suggestion but failed again, same problem.
I followed your steps in TIA PORTAL V16.
But in Simatic Manger Factory IO runs. :thinking:
Also can you tell me how can I write more than 3 times?

@m_imrak The forum has a default security measure that prevents a user from making more than 3 posts in a row. I have increased it to 5 so it’s more tolerant.

Hi m_imrak,

Must say that I had to reinstall PLCSim because I had some issues with it. Think that a recent Microsoft Windows 10 update created the issue.

  • Used CPU = 6ES7 314-6EH04-0AB0
  • TIA Portal version = V15.1
  • PLCSim version = V5.4 SP8
  • Factory IO version = 2.4.5

Hi geert.vangrieken,
Thank you for your replies. I will try to solve it and when I find a solution for my problem I will write here. :slightly_smiling_face:

1 Like