S7-PLCSIM 1500 problem with connection

Hi, I have a problem trying to connect to s7-plcsim 1500 I am using the template from the creators website and it doesn’t do anything I can only connect to S7-300 with 1200/1500 I don’t want to because it pops up a message that more than one instance is enabled I don’t know what to do anymore.

Thanks for Help

I have the same issue. I can’t connect the 1500, only the 1200.
Does anyone have a solution or fix?
The PLCSIM constantly flashes with an error light as well.
I haven’t done anything to the program, only downloaded the file from Factory IO and tried to connect.

Hi @mateusz.jakubiak and @DJM45 !

Can you tell me more about the error you are getting?
Make sure you are downloading the correct files, in your case, the ones for S7-1500, or else it won’t work. You can find them here.
Any print screens, of information, that you could share might help us understand what could be the issue.

Hi, here is a video.
In the first part i load the 1500 file, downloaded from Factory io website.
As you can see the plc sim goes straight into error. I try to connect but it does not allow it.

In the second part, i load the 1200 file downloaded from factory io and there is no issue.
Factory IO v2.5.4

I really hope this can be fixed.

Hi @DJM45.

Thank you for the video. I’ve recreated your steps in our lab, but I didn’t have any issue connecting to the PLCSIM and to Factory I/O.

I suggest you first create a new project on TIA Portal, without the template, with the S7-1500 PLC you want to simulate. Then try to connect to PLCSIM. If the PLCSIM still gives you an error then it’s most likely an issue with the Siemens software and not the template. In that case, we can’t help you, and you’d have to contact Siemens about it.
If you don’t get any error on PLCSIM, then you can try to recreate our template. For that, you can follow the steps described in this post.


I tried two things today.

I downloaded v17 and followed the same steps in my video and it worked without issue.

I used another laptop with an older version of factory io and v16 and downloaded the file on the website and it also worked.