S7-PLCSIM not detected by Factory I/O

Hello everyone!

I hope you are all well. I’m new to the forums, but have been reading quite a bit on it concerning the issue that I have with S7-PLCSIM. Please note that this is on a computer that has TIA Portal v13 SP2 Update 4 installed, and S7-PLCSIM SP2 Update 4 as well. This was the given software to install on all computers in class.

As the title states, something very strange is happening. I’ve went to the Factory I/O site and downloaded the template for v13. At first (a few days ago), it worked perfectly fine! But now, as the project was about to be finalized, the laptop was turned on as usual, minor update on the code compiled successfully and everything was running in PLCSIM and HMI Simulator built-in. The FC9000 was never touched throughout all of this.

For some reason, I’m always getting the error: “It seems that PLCSIM is not running”. I’ve tried so many things, but all failed. I’ve tried running it as administrator, but nothing happened. I checked if the “siemens.simatic.plcsim.vplchost” is running during the simulation, and it is. Nothing happened. I tried creating a blank project (the template as it is) and a blank Factory I/O environment… nothing happened. I updated Factory I/O from 2.5.2 to 2.5.4… again, nothing happened. The error always persisted. I ran everything as Administrator, literally everything. I made sure that they are all set “for all users” as administrator too… it still gave me the same error “It seems that PLCSIM is not running”.

I checked this forum here:

But there are a couple of broken links there it seems that could’ve led to a more comprehensive solution. All I know is that the OP of that topic had the issue resolved in the end, but I have absolutely no clue what they did. Can you please help me out? It all suddenly happened today, by the way. They really were working completely fine some 2-3 days ago.

1 Like

Hi @Hexados,

This problem typically happens when you don’t run both applications with the same Windows privileges. Can you double-check that you are running Factory I/O and S7-PLCSIM as administrator?

Hello @brunovgr,

Thank you very much for your reply.

As stated, I ran all applications with Administrative privileges. I have double-checked, and confirm that this is not what’s causing this strange error. Everything is indeed running with Admin privileges.

To circumvent this, I have implemented NetToPLCSim and changed the driver from S7-PLCSIM to S7-1200/S7-1500. This did resolve the issue, but I would regardless like to know what is causing this issue to persist the way it is. For example, what if there was something wrong with NetToPLCSim and I couldn’t run it either (just an example)?

Only a couple of topics were opened on this particular problem, but none explain how to resolve it, or have broken links leading to 404 Not Found errors when redirecting.

I’m going to include a quick workaround for this particular and very annoying issue.
Software needed:

  • TIA Portal
  • Factory I/O (obviously)
  • NetToPLCSim (this is a completely free software)


  • Make sure that every single one of the above mentioned applications are opened with Administrative privileges.
  • Open TIA Portal, compile your code from scratch (“rebuild all”)
  • Run the simulator from within TIA Portal (do NOT open it standalone as it may not work)
  • Make sure that PLCSIM is in run mode, and keep in mind the IP Address you’ve allocated to your PLC within the environment.
  • Keep everything open, and go to “cmd” (command prompt), and run it as administrator.
  • Write the following command: ipconfig/all
  • You should see the IP Address that is assigned to your computer here if you are connected to a network.
  • If you are not connected to a network, create your own IP Address with a similar subnet mask. To those who do not know how to do this, please go to your WiFi located in the bottom right of the taskbar, and click it. Once the window opens, press “Change adapter options”.
  • You should see an option for your WiFi network adapter (i.e. Intel Wireless Network Adapter, or something like that). Right-Click it and go to Properties
  • Go down to “Internet Protocol Version 4” and double-click it. Here, you should see that “Obtain an IP Address Automatically” is selected. Select “Use the following IP Address”, and put the IP Address that you want (i.e. and a subnet mask of
  • Press OK, and close that window. Now you have a hosting IP Address that’s yours. Let’s assume that it is
  • Go to NetToPLCSim and open it (as Administrator). It will demand Port 102 to be given to it. Accept, and let it do its thing. (You should get a success message here)
  • Once you see that, press “Add”. Check back in TIA Portal what you named your PLC. By default, it’s PLC_1. If so, put PLC_1 in “Name”.
  • Network IP Address is the IP Address that you just allocated to yourself ( OR the one already given to you by the WiFi or Ethernet network you are in (again, you can see this in command prompt above using “ipconfig/all”. You need to see the IP Address with “(Preferred)” next to it)
  • PLCSIM IP Address is the address of the PLC. By default, this is, unless you changed it specifically.
  • Finally, Plcsim Rack / Slot should be “0” with “2” for all S7-300 and S7-400 PLCs, and “0” with “1” for all S7-1200 and S7-1500 PLCs.
  • You can now press “OK”, and start the server. If it says “RUNNING”, then all is good. You can minimize NetToPLCSim, but do not close it. Always keep it open.
  • Now you can go back to TIA Portal, and run the HMI Simulator too if you want.
  • Go to Factory I/O (as Administrator), and go to “Drivers” and then “Configuration”, and select “S7-1200/S7-1500” instead of S7-PLCSIM.
  • Still in Configuration, the “Host IP Address” is the same one as your computers’ (the one given by your network, or the one you manually defined (in our example, Of course, make sure to select the correct PLC as well.
  • At last, press “Connect” and see the magic happen.

A post was split to a new topic: PLCSIM - PLC might not be a trustworthy device

Hi @Hexados,

I have fixed the broken link. Thanks for pointing that out.

From your description, the S7-PLCSIM process (Siemens.Simatic.PlcSim.VplcHost) is running, but Factory I/O fails to find it. This may be caused by incorrect Windows account permissions or third-party software, such as an antivirus, that is blocking Factory I/O from accessing the system processes.

Nonetheless, I would like to look at the Factory I/O log file. Can you try to connect to S7-PLCSIM again using the S7-PLCSIM driver and send us the log file to support [at] realgames.pt? Don’t post it since it may contain sensitive information. See how to get the log file here.