Siemens PLCSIM Advanced2.0 - OPC UA connection problem with FIO

In TIA15.1upd4 I have a 1511-PN with OPC UA server enabled. No security is enabled.

I´m using PLCSIM Adv. 2.0 to simulate the PLC.
When I try to get FIO to connect to PLCSIM Advanced 2.0 SP1 using OPC Client DA/UA I get an error


I’m able to connect other OPC UA clientst to PLCSIM Advanced, like UaExpert1.5.1 using this endpoint url opc.tcp:// with out any problems. But it does not work in FIO.

Both FIO and PLCSIM is running with Admin rights.

1 Like

Hi @ChexLemeneux

Welcome to the forum!

Can you confirm that No security is the only security policy set on OPC UA > Server > Security > Secure Channel

1 Like


Thx for replying.

Here is a screen dump of the settings:

1 Like

After looking this up, it looks like the error 10013 is a Windows error (WinSock error). I found a similar issue reported at Microsoft support forum.

A common cause can be a firewall or antivirus software denying the connection to the socket. Please check whether the machine where Factory I/O and TIA Portal is running has a firewall/antivirus software installed and whether outbound TCP connections are allowed.

1 Like


Thank you for your patience and your time.

It is working now, it was a Firewall issue :flushed:

I was pretty sure that I did disable my firewall when I first experienced this issue, but apparently I did not.
(Yes I feel really stupid :roll_eyes: )

Thanks again for your support…

Can I somehow mark this thread as “Solved”?

1 Like

There is no way to mark a thread as solved.Your feedback is enough.

Thank you :+1:

1 Like