Trying to connect an ABB OPC server to Factory IO

Hi all!

I have a running OPC server from the ABB system and I can’t for the life of me figure out how to connect it to Factory IO. It just won’t show up! The OPC server is running on one pc and Factory IO on another but I’d think that wouldn’t be a problem. I’ve tried typing in “opc.tcp://” to look for available OPC servers but it says “No connection could be made because the targeted machine actively refused it”.

Any help would be much appreciated!

Bas Plevier

Hi @user102,

This error typically indicates that the OPC server is not running or the URL is not correct.
Can you post the complete server endpoint URL (opc.tcp://xxx.xxx.xxx.xxx:xxxx)?

Hi Bruno,

I just got it to work by installing Factory IO on the same pc as the server. The server name is ABB.AC800MC_OpcDaServer.3 and it’s in the dropdown menu in Factory IO. So the only question that remains is how do I get it to work using Factory IO on a different pc than the server is. The IP address of the server is 192.168.13.10.

Using OPC DA remotely can be quite challenging. You would need to configure DCOM on both client and server machines. Next, in Factory I/O, you would enter the server name in the Host Name input field in order to browse OPC servers on the remote machine. If you perform a quick search online using the terms “opc da dcom remotely” you can find several tutorials on how to properly configure DCOM. Maybe ABB provides one…

If the ABB system includes an OPC UA server, I would recommend it instead of OPC DA. OPC DA is an old technology that is being replaced by OPC UA. It’s much easier to use and works better when used remotely. When using OPC UA you would enter the server endpoint URL in Factory IO (opc.tcp://servername:portnumber). You can find the port number in the OPC UA server.

Is this “Host Name” the IP address of the server? Because whenever I try to do that I get the following message: “Operation is not valid due to the current state of the object”. Is there a specific format I should use? I just type in 192.168.13.10 now.

edit: I used this guide to set the DCOM settings: https://www.softwaretoolbox.com/dcom/html/dcom_for_windows_7-10--_server_2008r2.html.

It still doesn’t work though. It’s still giving the same error as before.

It looks like a DCOM error. Run Factory I/O on the computer running the OPC server and enter the hostname (IP / host name) in the “Host Name” and see if it can correctly browse servers. If this works the error you are seeing is most likely related to DCOM configuration.

Well Bruno… I got one step closer. When I type in the hosts ip address he shows me 3 options to pick from. The one I need is “ABB.AC800MC_OpcDaServer.3” but when I select it I get the following error: “The requested object was not found”. So he clearly sees the server now but something else goes wrong. Any idea what that might be?

This error also looks like a DCOM error. I would recommend that you use OPC UA, as an alternative to OPC DA when trying to connect to a remote OPC server. Does your ABB system include an OPC UA server?
If you can’t use OPC UA I recommend that you double-check the configuration of DCOM, both on client and server computers.